Tests delayed in London region

Incident Report for Calibre

Resolved

This incident has been resolved.
Posted Oct 06, 2020 - 07:57 AEDT

Monitoring

There is a backlog of tests in the London region. We are continuing to monitor the situation while the backlog is being processed.
Posted Oct 05, 2020 - 22:40 AEDT
This incident affected: Test Agents (London).